Problem
Ich habe eine komplexe Versandart-Struktur und ich möchte, dass diese logisch, übersichtlich und automatisierbar verwaltet wird
Ursache
Die häufigsten Kriterien für eine Versandart sind:
- Zielland
- Plattform
- Gewicht
- Länge der längsten Seite
Die Entscheidungsmatrix ist dementsprechend häufig 3-5 dimensional. Das lässt sich in einer Tabelle nicht darstellen. Die Übersicht darüber zu behalten ist schon schwer genug. Noch schwieriger ist es für den Mitarbeiter jetzt die korrekte Versandart zu wählen.
Lösungen
Statefulness
Der zentrale Ansatz ist es zunächst, die Versandart "stateful" zu machen - Sie also so zu definieren, dass sie zu jedem Zeitpunkt eindeutig bestimmbar ist. Ändert sich der Inhalt des Auftrags, ändert sich unter Umständen auch die geeignetste Versandar.
Struktur
Damit man dies an einer zentralen Stelle verwalten kann, sollte man auf keinen Fall dafür mehrere Workflows für "Auftrag erstellt" anlegen. Das wird früher oder später zu einem nicht mehr beherrschbaren Chaos führen.
Viel besser ist der Ansatz, alle Definitionen in einen gesammelten manuellen Workflow zu verpacken.
Dabei gewinnt immer der letzte zutreffende Workflow. Man kann diesen manuellen Workflow viel einfacher warten und auch testen, da dieser jederzeit direkt ausführbar ist.
In der Regel sieht so eine Entscheidungsmatrix (stark vereinfacht) wie folgt in JTL aus:
Aufgrund des Aufbaus können so problemlos mehrere Definitionen miteinander kombiniert werden. Da alle einzelnen Workflows immer zusammen durchgeführt werden.
Referenzieren statt Kopieren
Dieser erstellte Workflow wird dann bei Auftrag erstellt und Auftrag geändert nur noch referenziert. So ist sichergestellt, dass
- Bei Änderungen am Workflow, immer auch beide Auslöser diese Änderungen erhalten
- Die Aufträge immer und durchgehend die korrekte Versandart haben (der Workflow überschreibt ad hoc alle Änderungen am Auftrag sofort wieder)
- Die Workflows strukturiert und aufgeräumt bleiben, weil die Workflows thematisch und inhaltlich gegliedert bleiben
Fazit
Manchmal muss Ordnung einfach sein und ist auch der Schlüssel für eine gute Workflow-Struktur. Falls ihr Hilfe braucht, sprecht uns gerne an.
Übrigens: Mit ein bisschen Hacken, kann man auch Workflows aus Auftrag erstellt in einen manuellen Workflow verschieben, ohne alles neu machen zu müssen - Also wir können das ;-)
Kommentare
0 Kommentare
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.